BuiltInFailures.PerformanceFailures Class


Built In Failures Performance Failures Class

Failures which give hints pointing to situations where performance could be improved.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures PerformanceFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class PerformanceFailures

The BuiltInFailures PerformanceFailures type exposes the following members.

Properties
Name Description
Public property Static member ClippingIsDisabled View has clipping disabled. It causes view to draw too many elements.
Public property Static member DisjoinedSolidsInInPlaceFamily In-place family contains multiple disjoined solids. Consider splitting in several in-place families.
Public property Static member DuplicateInstances There are duplicate instances of the same family in the same place. Delete duplicate instances to improve performance.
Public property Static member FamilyContainsViewSpecificImports Family definition contains view-specific imports. Such imports are inaccessible in the project - consider removal.
Public property Static member HostHasTooManyInserts Host object contains too many cutting inserts - it may take long time to update. Consider splitting host object into smaller pieces or using stacked walls.
Public property Static member InteriorCategoriesEnabledInLargeView Interior categories are enabled in a large view. Even though these objects may be obscured and invisible, they still have negative impact on performance.
Public property Static member LargeFamilyFile Family occupies XXX kilobytes of memory. Consider simplification of the family.
Public property Static member ManyElementInFamily Family definition contains too many elements. Consider simplification of the family.
Public property Static member ManyUnusedNestedFamilies Family contains other families loaded into it but not used. Consider purging family document from unused families and types.
Public property Static member MultipleLoopsInSketch Sketch of <element> contains multiple independent loops - splitting it in few independent elements might improve performance.
Public property Static member TooLargeSketch Sketch of <element> has large area - it may slow down selection, drawing and geometric computations.
Public property Static member TooManyAreaBoundaryLinesFound There are too many area boundary lines in area scheme <element> might result in increased model sizes on disk and in memory. Please investigate if area scheme is used in a proper way.
Public property Static member TooManyElementsInSketch Sketch of <element> contains too many objects - it may take long time to solve.
Public property Static member UnjoinedRoomSeparationLinesFound Room Separation of <element> is not joined, might cause performance issue with room boundaries computations.
Public property Static member UnusedTypesInTheProject Project contains unused families and/or types. Consider purging them out.
Public property Static member ViewDetailLevelIsHighInLargeView A large view has view detail level set to medium or coarse. Generation of extraneous details harms performance.
Public property Static member WallsOverlap Walls overlap. Consider embedding walls, editing their extents or profile to avoid overlapping.
Top
See Also