Area |
Returns a transform representing the movement of the line relative to its default position along the direction of the desired layer.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public Transform GetMovedLineTransform(
AreaReinforcementLayerType layer,
int linePositionIndex
)
Parameters
- layer AreaReinforcementLayerType
- The layer on which the line stays.
- linePositionIndex Int32
- The index of the line from the desired layer. It should be an index between 0 and (NumberOfLines-1).
Return Value
TransformThe transform representing the movement of the line relative to its default position along the direction of the desired layer.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | linePositionIndex is not in the range [ 0, NumberOfLines-1 ]. -or- A value passed for an enumeration argument is not a member of that enumeration |
InapplicableDataException | The layer layer isn't active. |
InvalidOperationException | This AreaReinforcement does not host Rebar. |