GetDeletedElementIds Method


Updater Data Get Deleted Element Ids Method

Returns set of elements that were deleted from the document. This set is mutually exclusive of elements returned by getAddedElementIds() and getModifiedElementIds().

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ICollection<ElementId> GetDeletedElementIds()

Return Value

ICollection ElementId
Set of elements that were deleted from the document and triggered the call to execute() Note: This will only return elements if the trigger registered for the associated updater contains the ChangeType returned by Element::getChangeTypeElementDeletion()
See Also