PolylineSegments Class


Polyline Segments Class

An output node that represents a tessellated polyline segments.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB PolylineSegments

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PolylineSegments : IDisposable

The PolylineSegments type exposes the following members.

Properties
Name Description
Public property EndLocalParameter Local parameter associated with the end point.
Public property EndParameter Parameter associated with the end point.
Public property IsFilled Indicates whether the area enclosed by the polyline is to be filled or not.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property LineProperties Access to the line (pen) properties of the polyline
Public property StartLocalParameter Local parameter associated with the start point.
Public property StartParameter Parameter associated with the start point.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the PolylineSegments
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method GetVertices Returns an array of vertices of the polyline segments.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
Remarks
See Also