Current Property


Filtered Element Id Iterator Current Property

Gets the item at the current position of the iterator.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public virtual ElementId Current { get; }

Property Value

ElementId

Implements

IEnumerator T Current
Exceptions
Exception Condition
InvalidOperationException There is no current item in the iterator.
Remarks
There is no current item if the iterator has not started yet or has been done.
See Also