Category |
A map that contains a mapping of category name to its category object.

System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB CategoryNameMap
Autodesk.Revit.DB Categories
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB CategoryNameMap
Autodesk.Revit.DB Categories
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The CategoryNameMap type exposes the following members.

Name | Description | |
---|---|---|
![]() | CategoryNameMap | Initializes a new instance of the CategoryNameMap class |

Name | Description | |
---|---|---|
![]() | IsEmpty | Test to see if the map is empty. |
![]() | Item | Gets or sets a category at a specified name within the map. |
![]() | Size | Returns the number of categories that are in the map. |

Name | Description | |
---|---|---|
![]() | Clear | Removes every category from the map, rendering it empty. |
![]() | Contains | Tests for the existence of a category with that name within the map. |
![]() | Erase | Removes a category with the specified name from the map. |
![]() | ForwardIterator | Retrieve a forward moving iterator to the map. |
![]() | GetEnumerator | Retrieve a forward moving iterator to the map. |
![]() | Insert | Insert the specified category with the specified name into the map. |
![]() | ReverseIterator | Retrieve a backward moving iterator to the map. |