CreateStartConstraint Method


Rebar Trim Extend Data Create Start Constraint Method

Creates a constraint for the start handle of the rebar. This constraint will be set preferred after the API execution is finished successfully.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool CreateStartConstraint(
	IList<Reference> targetReferences,
	bool isConstraintToCover,
	double offsetValue
)

Parameters

targetReferences IList Reference
The references to which the rebar handle will be constrained. Will throw exception if it's empty or if it's anything but Face(s) from a structural that can host rebar.
isConstraintToCover Boolean
If true the RebarConstraintType will be set to ToCover, otherwise RebarConstraintType will be set to FixedDistanceToHostFace.
offsetValue Double
The distance from references to the rebar handle.

Return Value

Boolean
Returns true if a start constraint can be created with the given references, false otherwise. The reference should be faces from structurals that can host rebar.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also