DistributionType Property


Rebar Distribution Type Property

Note: This API is now obsolete.

The type of rebar distribution(also known as Rebar Set Type).

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
[ObsoleteAttribute("<p> This property is deprecated in Revit 2025 and may be removed in a later version of Revit. The property Autodesk.Revit.DB.Structure.RebarShapeDrivenAccessor.UseRebarConstraintsToProduceVaryingBars can be used instead. </p> <p>To check if the set can have (but not necessary have) varying length bars you can use Autodesk.Revit.DB.Structure.Rebar.CanHaveVaryingLengthBars. To check if the set has varying length bars you can use Autodesk.Revit.DB.Structure.Rebar.HasVaryingLengthBars.</p>")]
public DistributionType DistributionType { get; set; }

Property Value

DistributionType
Exceptions
Exception Condition
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
Remarks
The possible values of this property are:
  • Uniform
  • VaryingLength
For a uniform distribution type: all bars' parameters are the same as the first bar in set. For a varying length distribution type: bars parameters can vary(primarily in length) taking in consideration the constraints of the first bar in set.
See Also