AppendShape Method (IList(GeometryObject), DirectShapeTargetViewType)


Direct Shape Append Shape(IList Geometry Object , Direct Shape Target View Type) Method

Appends the collection of GeometryObjects into the model or view specific shape representation stored in this DirectShape. Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AppendShape(
	IList<GeometryObject> pGeomArr,
	DirectShapeTargetViewType viewType
)

Parameters

pGeomArr IList GeometryObject
Shape expressed as a collection of GeometryObjects. For viewType = DirectShapeTargetViewType::Default, the supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve. For viewType = DirectShapeTargetViewType::Plan, the supported types of GeometryObjects are: Point and Curve.
viewType DirectShapeTargetViewType
Passing DirectShapeTargetViewType.Default as view type will cause the default shape to be appended.
Exceptions
Exception Condition
ArgumentException At least one member of pGeomArr does not satisfy DirectShape validation criteria.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Remarks
The existing shape will not be cleared by this function, and intersecting or overlapped geometry will not be joined with the appended geometry. It is up to the caller to ensure that the combination of geometry will have the correct appearance in Revit.
See Also