GetLastSavedReferenceData Method


Transmission Data Get Last Saved Reference Data Method

Gets the ExternalFileReference representing path and load status information concerning the most recent time this TransmissionData's document was opened.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ExternalFileReference GetLastSavedReferenceData(
	ElementId elemId
)

Parameters

elemId ElementId
The ElementId of the Element which the external file reference is a component of.

Return Value

ExternalFileReference
An ExternalFileReference containing the previous path and load status information for an external file
Exceptions
Exception Condition
ArgumentException elemId does not correspond to an ExternalFileReference contained in this TransmissionData.
ArgumentNullException A non-optional argument was null
See Also