DocumentClosed Event


Application Document Closed Event

Subscribe to the DocumentClosing event to be notified when Revit is just about to close a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public event EventHandler<DocumentClosedEventArgs> DocumentClosed

Value

EventHandler DocumentClosedEventArgs
Remarks

This event is raised immediately after Revit has finished closing a document. It is raised even when document closing failed or was cancelled (during DocumentClosing event).

This event is not cancellable, for the process of closing document has already been finished.

The document cannot be modified because the corresponding object does not exist anymore.

See Also