View3D Class


View 3D Class

Class for 3D views
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class View3D : View

The View3D type exposes the following members.

Properties
Name Description
Public property AnalysisDisplayStyleId Element id of Analysis Display Style associated with the view.
(Inherited from View )
Public property AreAnalyticalModelCategoriesHidden Indicates if analytical model categories are currently hidden in the view.
(Inherited from View )
Public property AreAnnotationCategoriesHidden Indicates if annotation categories are currently hidden in the view.
(Inherited from View )
Public property AreCoordinationModelHandlesHidden Indicates if Coordination Model handles are currently hidden in the view.
(Inherited from View )
Public property AreImportCategoriesHidden Indicates if import categories are currently hidden in the view.
(Inherited from View )
Public property AreModelCategoriesHidden Indicates if model categories are currently hidden in the view.
(Inherited from View )
Public property ArePointCloudsHidden Indicates if point clouds are currently hidden in the view.
(Inherited from View )
Public property AssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element )
Public property AssociatedAssemblyInstanceId The Id of the assembly instance that owns the assembly view.
(Inherited from View )
Public property Code example BoundingBox Retrieves a box that circumscribes all geometry of the element.
(Inherited from Element )
Public property CanBePrinted Test whether the view can be printed.
(Inherited from View )
Public property Category Retrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element )
Public property Code example CreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element )
Public property CropBox The Crop Box applied to the view, or an outline encompassing the crop region applied to the view.
(Inherited from View )
Public property CropBoxActive Whether or not the Crop Box/Region is active for the view.
(Inherited from View )
Public property CropBoxVisible Whether or not the Crop Box/Region is visible for the view.
(Inherited from View )
Public property Code example DemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element )
Public property Code example DesignOption Returns the design option to which the element belongs.
(Inherited from Element )
Public property DetailLevel The detail level of this view.
(Inherited from View )
Public property Discipline The Discipline of the view.
(Inherited from View )
Public property DisplayStyle The DisplayStyle of the view. Returns DisplayStyle.Wireframe if the view has no display style.
(Inherited from View )
Public property Document Returns the Document in which the Element resides.
(Inherited from Element )
Public property GenLevel The level for the view.
(Inherited from View )
Public property Code example Geometry Retrieves the geometric representation of the element.
(Inherited from Element )
Public property GroupId The id of the group to which an element belongs.
(Inherited from Element )
Public property Code example Id A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element )
Public property IsAssemblyView Indicates if the view is assembly view.
(Inherited from View )
Public property IsCallout Indicates if the view is a callout view.
(Inherited from View )
Public property IsLocked Indicates if the view is locked.
Public property IsModifiable Identifies if the element is modifiable.
(Inherited from Element )
Public property IsPerspective Identifies whether this is a perspective view.
Public property Code example IsSectionBoxActive Identifies whether or not the section box is active in this 3D view.
Public property IsTemplate Test whether the view is a view template.
(Inherited from View )
Public property IsTransient Indicates whether an element is transient or permanent.
(Inherited from Element )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element )
Public property LevelId The id of the level associated with the element.
(Inherited from Element )
Public property Code example Location This property is used to find the physical location of an element within a project.
(Inherited from Element )
Public property Name A human readable name for the Element.
(Inherited from Element )
Public property Origin Returns the origin of the screen.
(Inherited from View )
Public property Outline The bounds of the view in paper space (in feet).
(Inherited from View )
Public property OwnerViewId The id of the view that owns the element.
(Inherited from Element )
Public property Code example Parameter BuiltInParameter Retrieves a parameter from the element given a parameter id.
(Inherited from Element )
Public property Parameter Definition Retrieves a parameter from the element based on its definition.
(Inherited from Element )
Public property Parameter Guid Retrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element )
Public property Code example Parameters Retrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element )
Public property ParametersMap Retrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element )
Public property PartsVisibility The visibility setting for parts in this view.
(Inherited from View )
Public property Pinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element )
Public property ProjectGridsOnSectionBox This option projects all grids from the current 3d view on the bottom face of the section box. Only grids that are inside or intersects the section box
Public property RevealConstraintsMode Indicates whether the Reveal Constraints mode is activated in the view.
(Inherited from View )
Public property RightDirection The direction towards the right side of the screen.
(Inherited from View )
Public property Scale The scale of the view.
(Inherited from View )
Public property ShadowIntensity The intesity of cast shadows - 0 = no shadows, 100 = black.
(Inherited from View )
Public property SketchPlane The sketch plane assigned to the view for model curve creation.
(Inherited from View )
Public property SunAndShadowSettings The sun and shadow settings assigned to the view for shadow calculation and rendering.
(Inherited from View )
Public property SunlightIntensity The intensity of the simulated (directional) sunlight. 0 = no directional light; maximum value is 100.
(Inherited from View )
Public property TemporaryViewModes Data of temporary view modes associated with this view.
(Inherited from View )
Public property Title The view title. This consists of the view name plus other modifiers, such as the view type, sheet number, area scheme, and/or assembly type, depending on the specifics of the view.
(Inherited from View )
Public property Code example UniqueId A stable unique identifier for an element within the document.
(Inherited from Element )
Public property UpDirection The direction towards the top of the screen.
(Inherited from View )
Public property VersionGuid Get the element version Guid.
(Inherited from Element )
Public property ViewDirection The direction towards the viewer.
(Inherited from View )
Public property ViewSpecific Identifies if the element is owned by a view.
(Inherited from Element )
Public property ViewTemplateId The id of the template view that controls this view's parameters.
(Inherited from View )
Public property Code example ViewType The type of the view.
(Inherited from View )
Public property WorksetId Get Id of the Workset which owns the element.
(Inherited from Element )
Top
Methods
Name Description
Public method AddFilter Adds a filter to the view.
(Inherited from View )
Public method AllowsAnalysisDisplay Identifies if this view allows display of Analysis results.
(Inherited from View )
Public method ApplyViewTemplateParameters Applies to this view the parameters of the input view that are not controlled by the current view template.
(Inherited from View )
Public method AreGraphicsOverridesAllowed Determines if Visibility/Graphics Overriddes can be applied to the view.
(Inherited from View )
Public method ArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element )
Public method CanApplyColorFillScheme Checks if the id can be applied as the scheme id of specified category to this view.
(Inherited from View )
Public method CanBeHidden Indicates if the element can be hidden in the view.
(Inherited from Element )
Public method CanBeLocked Identifies if the element can be locked.
(Inherited from Element )
Public method CanCategoryBeHidden Checks whether the category can be hidden in the view.
(Inherited from View )
Public method CanCategoryBeHiddenTemporary Check if category can be temporarily hidden in the view.
(Inherited from View )
Public method CanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element )
Public method CanEnableTemporaryViewPropertiesMode Indicates if Temporary View Properties mode can be applied for view in current state.
(Inherited from View )
Public method CanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element )
Public method CanModifyDetailLevel Check if Detail Level can be modified.
(Inherited from View )
Public method CanModifyDisplayStyle Indicates if DisplayStyle can be modified.
(Inherited from View )
Public method CanModifyViewDiscipline Indicates if the View Discipline can be modified
(Inherited from View )
Public method CanResetCameraTarget Checks whether the camera target can be reset for this view.
Public method CanSaveOrientation Returns true if the View3D's orientation can be saved, false otherwise.
Public method CanToggleBetweenPerspectiveAndIsometric Checks whether this view can toggle between perspective and isometric.
Public method CanUseDepthCueing Indicates if view can use Depth Cueing
(Inherited from View )
Public method CanUseTemporaryVisibilityModes Indicates if view can use temporary visibility modes
(Inherited from View )
Public method CanViewBeDuplicated Identifies if this view can be duplicated.
(Inherited from View )
Public method ChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element )
Public method ConvertTemporaryHideIsolateToPermanent Convert all temporary hidden elements or categories to permanently hidden in view.
(Inherited from View )
Public method Code example ConvertToIndependent Convert the dependent view to independent.
(Inherited from View )
Public method Static member Code example CreateIsometric Returns a new isometric View3D.
Public method Static member Code example CreatePerspective Returns a new perspective View3D.
Public method CreateViewTemplate Creates a new view template instance from this view instance.
(Inherited from View )
Public method DeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element )
Public method DeleteSubelement Removes a subelement from the element.
(Inherited from Element )
Public method DeleteSubelements Removes the subelements from the element.
(Inherited from Element )
Public method DisableTemporaryViewMode Disables the specified temporary view mode.
(Inherited from View )
Public method Dispose
(Inherited from Element )
Public method Code example Duplicate Duplicates this view.
(Inherited from View )
Public method EnableRevealHiddenMode Enables Reveal Hidden elements mode.
(Inherited from View )
Public method EnableTemporaryViewPropertiesMode Turns Temporary View Properties mode on or off. In this mode, any changes made to the view are temporary and will be discarded once the mode is disabled.
(Inherited from View )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method EvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element )
Public method EvaluateParameterValues Evaluate the parameters' values of the element on the given parameter ID set.
(Inherited from Element )
Public method GetBackground Returns the current background set for the view.
(Inherited from View )
Public method GetCalloutParentId Gets ID of the callout parent view.
(Inherited from View )
Public method GetCategoryHidden Checks if elements of the given category are set to be invisible (hidden) in this view.
(Inherited from View )
Public method GetCategoryOverrides Gets graphic overrides for a category in view.
(Inherited from View )
Public method GetColorFillSchemeId Returns id of the color fill scheme element applied to the view.
(Inherited from View )
Public method GetCropRegionShapeManager Returns an object for managing view crop region shape.
(Inherited from View )
Public method GetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element )
Public method GetDependentViewIds Get the ids of dependent views.
(Inherited from View )
Public method GetDepthCueing Returns the current depth cueing settings for the view.
(Inherited from View )
Public method GetDirectContext3DHandleOverrides Returns DirectContext3D handle overrides object for the view.
(Inherited from View )
Public method GetElementOverrides Gets graphic overrides for an element in the view.
(Inherited from View )
Public method GetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element )
Public method GetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element )
Public method GetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element )
Public method GetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element )
Public method GetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element )
Public method GetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element )
Public method GetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element )
Public method GetFilterOverrides Gets graphic overrides that a filter applies to the view.
(Inherited from View )
Public method GetFilters Gets the filters applied to the view.
(Inherited from View )
Public method GetFilterVisibility Gets the visibility of the elements associated with a filter.
(Inherited from View )
Public method Code example GetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element )
Public method GetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetIsFilterEnabled Identifies if the filter is enabled in this view.
(Inherited from View )
Public method GetLevelsThatShowGrids Returns the list of levels ids where grids are displayed in this 3D view.
Public method Code example GetLinkOverrides Gets the graphic overrides of a RevitLinkType or RevitLinkInstance in view.
(Inherited from View )
Public method GetMaterialArea Gets the area of the material with the given id.
(Inherited from Element )
Public method GetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element )
Public method GetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element )
Public method GetModelToProjectionTransforms Gets the transforms from the model space to the view projection space.
(Inherited from View )
Public method GetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element )
Public method GetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element )
Public method GetNonControlledTemplateParameterIds Returns a list of parameters that are not marked as included when this view is used as a template.
(Inherited from View )
Public method GetOrderedFilters Gets the filters applied to the view in the order they are applied.
(Inherited from View )
Public method GetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element )
Public method GetOrientation Gets the current non-saved orientation of the View3D.
Public method GetParameter Retrieves a parameter from the element given identifier.
(Inherited from Element )
Public method GetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element )
Public method GetParameters Retrieves the parameters from the element via the given name.
(Inherited from Element )
Public method GetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element )
Public method GetPlacementOnSheetStatus Determines if this view placed on a sheet completely or partially.
(Inherited from View )
Public method GetPointCloudOverrides Returns point cloud overrides object for the view.
(Inherited from View )
Public method GetPrimaryViewId Get the id of the primary view.
(Inherited from View )
Public method GetReferenceCallouts Returns element ids of all reference callouts in the view.
(Inherited from View )
Public method GetReferenceElevations Returns element ids of all reference elevations in the view.
(Inherited from View )
Public method GetReferenceSections Returns element ids of all reference sections in the view.
(Inherited from View )
Public method Code example GetRenderingSettings Returns the current rendering settings for this 3d view.
Public method GetSavedOrientation Gets the saved orientation of the View3D.
Public method GetSectionBox Gets a copy of the section box for this 3D view.
Public method GetSketchyLines Returns the current sketchy lines settings for the view.
(Inherited from View )
Public method GetSubelements Returns the collection of element subelements.
(Inherited from Element )
Public method GetTemplateParameterIds Returns a list of parameter ids that may be controlled when this view is assigned as a template.
(Inherited from View )
Public method GetTemporaryViewPropertiesId When Temporary View Properties mode is in progress it provides view id that overrode settings for current view. Outside Temporary View Properties mode InvalidElementId will be returned.
(Inherited from View )
Public method GetTemporaryViewPropertiesName When Temporary View Properties mode is in progress, name of applied template is returned. Outside Temporary View Properties mode, empty string will be returned.
(Inherited from View )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Code example GetTypeId Returns the identifier of this element's type.
(Inherited from Element )
Public method GetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element )
Public method GetViewDisplayModel Returns the current view display model settings for the view.
(Inherited from View )
Public method GetWorksetVisibility Returns the visibility settings of a workset for this particular view.
(Inherited from View )
Public method GetWorksharingDisplayMode Gets the current worksharing display mode for this view.
(Inherited from View )
Public method HasBeenLocked Identifies if the view has ever been locked.
Public method HasDetailLevel Check if the view has a Detail Level property
(Inherited from View )
Public method HasDisplayStyle Indicates if view has a DisplayStyle property
(Inherited from View )
Public method HasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element )
Public method HasViewDiscipline Indicates if the view has a Discipline property
(Inherited from View )
Public method HasViewTransforms Returns true if the view reports model space to view projection space transforms.
(Inherited from View )
Public method HideActiveWorkPlane Hide the active work plane of the view.
(Inherited from View )
Public method HideCategoriesTemporary Set multiple categories to be temporarily hidden in the view.
(Inherited from View )
Public method HideCategoryTemporary Set one category to be temporarily hidden in the view.
(Inherited from View )
Public method HideElements Sets the elements to be hidden in the view.
(Inherited from View )
Public method HideElementsTemporary Set multiple elements to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input.
(Inherited from View )
Public method HideElementTemporary Set one element to be temporarily hidden in the view. To hide a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input.
(Inherited from View )
Public method HideGridsOnLevel This method hides the grid lines in this 3D view on the given Level.
Public method IsCategoryOverridable Checks whether the category can have graphic overrides in this view.
(Inherited from View )
Public method IsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element )
Public method IsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element )
Public method IsElementVisibleInTemporaryViewMode Identifies if the input element is visible for the temporary view mode for this view.
(Inherited from View )
Public method IsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element )
Public method IsFilterApplied Indicates if a filter is applied to the view.
(Inherited from View )
Public method IsHidden Identifies if the element has been permanently hidden in the view.
(Inherited from Element )
Public method IsInTemporaryViewMode Returns true if the view is in a particular temporary view mode.
(Inherited from View )
Public method IsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element )
Public method IsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element )
Public method IsolateCategoriesTemporary Set categories to be temporarily isolated in the view.
(Inherited from View )
Public method IsolateCategoryTemporary Set one category to be temporarily isolated in the view.
(Inherited from View )
Public method IsolateElementsTemporary Set multiple elements to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input.
(Inherited from View )
Public method IsolateElementTemporary Set one element to be temporarily isolated in the view. To isolate a group completely, you must also include all members of all groups and nested groups in your input, therefore you should use the version of this method that accepts multiple element ids as input.
(Inherited from View )
Public method IsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element )
Public method IsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element )
Public method IsTemporaryHideIsolateActive Indicates if the view is temporarily hiding or isolating elements or categories.
(Inherited from View )
Public method IsTemporaryViewPropertiesModeEnabled Returns true when Temporary View Properties mode is in progress, false otherwise.
(Inherited from View )
Public method IsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element )
Public method IsValidViewTemplate Verifies that the view represented by templateId can be set as the controlling view template for this view.
(Inherited from View )
Public method IsViewValidForTemplateCreation Verifies that the view is valid for template creation.
(Inherited from View )
Public method IsWorksetVisible Indicates whether the workset is visible in this view.
(Inherited from View )
Public method LookupParameter Attempts to find a parameter on the element which has the given name.
(Inherited from Element )
Public method OrientTo Reorients the view to align with the forward direction.
Public method Print Print this view with the default view template and using the print setting of the current active document.
(Inherited from View )
Public method Print(Boolean) Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document.
(Inherited from View )
Public method Print(View) Print this view with the given view template and using the print setting of the current active document.
(Inherited from View )
Public method Print(View, Boolean) Print this view with the given view template, and either the view's document's print setting or the print setting of the current active document.
(Inherited from View )
Public method RefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element )
Public method RefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element )
Public method RemoveCalloutParent Replaces callout parent ID with InvalidElementId.
(Inherited from View )
Public method RemoveFilter Removes a filter from the view.
(Inherited from View )
Public method Code example RemoveLinkOverrides Deletes the graphical link overrides in the current view.
(Inherited from View )
Public method ResetCameraTarget Resets the camera target to the center of the field of view.
Public method RestoreCalloutParent Restores callout parent ID to the original view ID if that view is still available.
(Inherited from View )
Public method RestoreOrientationAndLock Locks the view and restores its orientation.
Public method SaveOrientation Converts the temporary orientation of the View3D into its saved orientation.
Public method SaveOrientationAndLock Locks the view and saves its orientation
Public method ScalePerspectiveCropBox Scale an existing crop box of the perspective view.
Public method SetBackground Sets the background for the view. Background can only be set for 3d views and for Sections/Elevations.
(Inherited from View )
Public method SetCategoryHidden Sets if elements of the given category will be visible in this view.
(Inherited from View )
Public method SetCategoryOverrides Sets graphic overrides for a category in view.
(Inherited from View )
Public method SetColorFillSchemeId Applies color fill scheme to this view.
(Inherited from View )
Public method SetDepthCueing Sets the depth cueing settings for the view.
(Inherited from View )
Public method SetElementOverrides Sets graphic overrides for an element in the view.
(Inherited from View )
Public method SetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element )
Public method Code example SetFilterOverrides Sets the overrides associated with a filter.
(Inherited from View )
Public method SetFilterVisibility Sets the visibility of the elements associated with a filter.
(Inherited from View )
Public method SetIsFilterEnabled Sets the filter enabled flag.
(Inherited from View )
Public method Code example SetLinkOverrides Sets the graphic overrides of a RevitLinkType or RevitLinkInstance in the view.
(Inherited from View )
Public method SetNonControlledTemplateParameterIds Sets the parameters that will not be included when this view is used as a template.
(Inherited from View )
Public method SetOrientation Sets the temporary orientation of the View3D. The new orientation is not saved in the document.
Public method SetRenderingSettings Changes the rendering settings for this 3d view.
Public method Code example SetSectionBox Sets the section box for this 3D view.
Public method SetSketchyLines Sets the sketchy lines settings for the view.
(Inherited from View )
Public method SetViewDisplayModel Sets the view display model settings for the view.
(Inherited from View )
Public method SetWorksetVisibility Sets visibility for a workset in this view.
(Inherited from View )
Public method Code example SetWorksharingDisplayMode Sets the worksharing display mode for this view.
(Inherited from View )
Public method ShowActiveWorkPlane Show the active work plane of the view.
(Inherited from View )
Public method ShowGridsOnLevel This method displays the grid lines in this 3DView on the given Level.
Public method ShowGridsOnLevels This method displays the grid lines in this 3D view on the given Levels.
Public method SupportedColorFillCategoryIds Returns collection of all category ids that correspond to elements that can potentially be colored in this view according to a color fill scheme. The set may be different depending on the view type.
(Inherited from View )
Public method SupportsRevealConstraints Checks that the view can have the Reveal Constraints mode activated.
(Inherited from View )
Public method SupportsWorksharingDisplayMode Checks whether this view supports the given worksharing display mode.
(Inherited from View )
Public method ToggleToIsometric Toggles this view to isometric.
Public method ToggleToPerspective Toggles this view to perspective.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Public method UnhideElements Sets the elements to be shown in the given view if they are currently hidden.
(Inherited from View )
Public method Unlock Unlocks the view. Has no effect if the view is already unlocked.
Top
Example
private void Getinfo_View3D(View3D view3D)
{
    string message = "View3D: ";

    // The position of the camera.
    XYZ eyePosition = view3D.GetOrientation().EyePosition;
    message += "\nCamera position: " + eyePosition;

    // Identifies whether the view is a perspective view. 
    if (view3D.IsPerspective)
    {
        message += "\nThe view is a perspective view.";
    }

    // The section box of the 3D view can cut the model.
    if (view3D.IsSectionBoxActive)
    {
        BoundingBoxXYZ sectionBox = view3D.GetSectionBox();

        // Note that the section box can be rotated and transformed.  
        // So the min/max corners coordinates relative to the model must be computed via the transform.
        Transform trf = sectionBox.Transform;

        XYZ max = sectionBox.Max; //Maximum coordinates (upper-right-front corner of the box before transform is applied).
        XYZ min = sectionBox.Min; //Minimum coordinates (lower-left-rear corner of the box before transform is applied).

        // Transform the min and max to model coordinates
        XYZ maxInModelCoords = trf.OfPoint(max);
        XYZ minInModelCoords = trf.OfPoint(min);

        message += "\nView has an active section box: ";
        message += "\n'Maximum' coordinates: " + maxInModelCoords;
        message += "\n'Minimum' coordinates: " + minInModelCoords;
    }
    TaskDialog.Show("Revit", message);
}
See Also