View3D Class


View 3D Class

Class for 3D views
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class View3D : View

The View3D type exposes the following members.

Properties
Name Description
Public property IsLocked Indicates if the view is locked.
Public property IsPerspective Identifies whether this is a perspective view.
Public property Code example IsSectionBoxActive Identifies whether or not the section box is active in this 3D view.
Public property ProjectGridsOnSectionBox This option projects all grids from the current 3d view on the bottom face of the section box. Only grids that are inside or intersects the section box
Top
Methods
Name Description
Public method CanResetCameraTarget Checks whether the camera target can be reset for this view.
Public method CanSaveOrientation Returns true if the View3D's orientation can be saved, false otherwise.
Public method CanToggleBetweenPerspectiveAndIsometric Checks whether this view can toggle between perspective and isometric.
Public method Static member Code example CreateIsometric Returns a new isometric View3D.
Public method Static member Code example CreatePerspective Returns a new perspective View3D.
Public method GetLevelsThatShowGrids Returns the list of levels ids where grids are displayed in this 3D view.
Public method GetOrientation Gets the current non-saved orientation of the View3D.
Public method Code example GetRenderingSettings Returns the current rendering settings for this 3d view.
Public method GetSavedOrientation Gets the saved orientation of the View3D.
Public method GetSectionBox Gets a copy of the section box for this 3D view.
Public method HasBeenLocked Identifies if the view has ever been locked.
Public method HideGridsOnLevel This method hides the grid lines in this 3D view on the given Level.
Public method OrientTo Reorients the view to align with the forward direction.
Public method ResetCameraTarget Resets the camera target to the center of the field of view.
Public method RestoreOrientationAndLock Locks the view and restores its orientation.
Public method SaveOrientation Converts the temporary orientation of the View3D into its saved orientation.
Public method SaveOrientationAndLock Locks the view and saves its orientation
Public method ScalePerspectiveCropBox Scale an existing crop box of the perspective view.
Public method SetOrientation Sets the temporary orientation of the View3D. The new orientation is not saved in the document.
Public method SetRenderingSettings Changes the rendering settings for this 3d view.
Public method Code example SetSectionBox Sets the section box for this 3D view.
Public method ShowGridsOnLevel This method displays the grid lines in this 3DView on the given Level.
Public method ShowGridsOnLevels This method displays the grid lines in this 3D view on the given Levels.
Public method ToggleToIsometric Toggles this view to isometric.
Public method ToggleToPerspective Toggles this view to perspective.
Public method Unlock Unlocks the view. Has no effect if the view is already unlocked.
Top
Example
private void Getinfo_View3D(View3D view3D)
{
    string message = "View3D: ";

    // The position of the camera.
    XYZ eyePosition = view3D.GetOrientation().EyePosition;
    message += "\nCamera position: " + eyePosition;

    // Identifies whether the view is a perspective view. 
    if (view3D.IsPerspective)
    {
        message += "\nThe view is a perspective view.";
    }

    // The section box of the 3D view can cut the model.
    if (view3D.IsSectionBoxActive)
    {
        BoundingBoxXYZ sectionBox = view3D.GetSectionBox();

        // Note that the section box can be rotated and transformed.  
        // So the min/max corners coordinates relative to the model must be computed via the transform.
        Transform trf = sectionBox.Transform;

        XYZ max = sectionBox.Max; //Maximum coordinates (upper-right-front corner of the box before transform is applied).
        XYZ min = sectionBox.Min; //Minimum coordinates (lower-left-rear corner of the box before transform is applied).

        // Transform the min and max to model coordinates
        XYZ maxInModelCoords = trf.OfPoint(max);
        XYZ minInModelCoords = trf.OfPoint(min);

        message += "\nView has an active section box: ";
        message += "\n'Maximum' coordinates: " + maxInModelCoords;
        message += "\n'Minimum' coordinates: " + minInModelCoords;
    }
    TaskDialog.Show("Revit", message);
}
See Also