LoadItemFiles Method


Fabrication Configuration Load Item Files Method

Loads the specified fabrication item files into the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<FabricationItemFile> LoadItemFiles(
	IList<FabricationItemFile> itemFiles
)

Parameters

itemFiles IList FabricationItemFile
The relative paths of the fabrication item files to load.

Return Value

IList FabricationItemFile
The relative paths of the fabrication item files which failed to load.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException The current fabrication configuration is not connected and updated to source configuration. Reload and try again. -or- this operation failed.
See Also