Key |
An iterator to a set of KeyBasedTreeEntry objects.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The KeyBasedTreeEntriesIterator type exposes the following members.

Name | Description | |
---|---|---|
![]() | Current | Gets the item at the current position of the iterator. |
![]() | CurrentObject | |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the KeyBasedTreeEntriesIterator |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object ) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object ) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object ) |
![]() | IsDone | Identifies if the iteration has completed. |
![]() | MoveNext | Increments the iterator to the next item. |
![]() | Reset | Resets the iterator to the initial state. |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object ) |