Solid |
This function facets (i.e., triangulates) a solid or an open shell. Each boundary component of the solid or shell is represented by a single triangulated structure.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static TriangulatedSolidOrShell TessellateSolidOrShell(
Solid solidOrShell,
SolidOrShellTessellationControls tessellationControls
)
Parameters
- solidOrShell Solid
- The solid or shell to be faceted.
- tessellationControls SolidOrShellTessellationControls
- This input controls various aspects of the triangulation.
Return Value
TriangulatedSolidOrShellThe triangulated structures corresponding to the boundary components of the input solid or the components of the input shell.

Exception | Condition |
---|---|
ArgumentException | solidOrShell is not valid for triangulation (for example, it contains no faces). |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | Unable to triangulate the solid or shell. |

Every point on the triangulation of a boundary component of the solid (or shell) should lie within the 3D distance specified by the "accuracy" input of some point on the triangulation, and vice-versa. In some cases, this constraint may be implemented heuristically (not rigorously).