Material Property


Fabrication Part Material Property

The fabrication material identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public int Material { get; set; }

Property Value

Int32
Exceptions
Exception Condition
ArgumentException When setting this property: the material is not valid for the fabrication part's specification.
InvalidOperationException When setting this property: the material is not able to be modified. -or- When setting this property: the fabrication part is connected to more than one item. -or- When setting this property: the material fails to be set by identifier: materialId.
See Also