SpacingRule Class


Spacing Rule Class

A rule for specifying a set of equidistant, parallel gridlines within a region.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SpacingRule : APIObject

The SpacingRule type exposes the following members.

Properties
Name Description
Public property BeltMeasurement On a curved surface, BeltMeasurement specifies where the grid's distances are measured.
Public property Distance The exact distance between layout lines.
Public property GridlinesRotation An additional rotation to be applied to this set of grid lines.
Public property HasBeltMeasurement True if the gridlines are not parallel due to surface curvature, and the BeltMeasurement property therefore applies.
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property Justification The justification of the lines within the region.
Public property Layout A choice of several gridline layout rules.
Public property Number The exact number of lines in the region.
Public property Offset An additional offset applied to the first gridline.
Top
Methods
Name Description
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetLayoutFixedDistance Set the Layout property to FixedDistance.
Public method SetLayoutFixedNumber Set the Layout property to FixedNumber.
Public method SetLayoutMaximumSpacing Set the Layout property to MaximumSpacing.
Public method SetLayoutMinimumSpacing Set the Layout property to MinimumSpacing.
Public method SetLayoutNone Set the Layout property to None.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also