StructuralWallUsageFilter Constructor (StructuralWallUsage, Boolean)


Structural Wall Usage Filter(Structural Wall Usage, Boolean) Constructor

Constructs a new instance of a filter to match walls that have the given structural wall usage, with the option to match all walls which are not of the given structural wall usage.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public StructuralWallUsageFilter(
	StructuralWallUsage structuralWallUsage,
	bool inverted
)

Parameters

structuralWallUsage StructuralWallUsage
The structural usage to match.
inverted Boolean
True if the filter should match all walls which are not of the given structural wall usage.
Exceptions
Exception Condition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also