IsCircuitPathValid Method


Electrical System Is Circuit Path Valid Method

Checks whether the list of the electrical system circuit path node position is valid.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool IsCircuitPathValid(
	IList<XYZ> nodes
)

Parameters

nodes IList XYZ
The list of the electrical system circuit path node position.

Return Value

Boolean
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
The length of the list should be more than one, the first node should be the position of the panel where the circuit begins at, the adjacent nodes should not be too close, and should be in the same level or on the same vertical line, to keep each segment of the circuit path always horizontal or vertical.
See Also