ViewRange Property


Revit Link Graphics Settings View Range Property

The view range of RevitLinkGraphicsSettings. The view range can be set to ByHostView or ByLinkView . Only a view that supports view range can have this property set to ByLinkView . To check if the view supports the view range use [!:Autodesk::Revit::DB::LinkVisibility::IsViewRangeSupported(Autodesk::Revit::DB::LinkVisibility)] . The LinkedViewId parameter must have a value assigned if this property is set to ByLinkView .

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public LinkVisibility ViewRange { get; set; }

Property Value

LinkVisibility
Exceptions
Exception Condition
ArgumentException When setting this property: Disallowed LinkVisibility value.
ArgumentOutOfRangeException When setting this property: A value passed for an enumeration argument is not a member of that enumeration
See Also