PipePressureDropData Class


Pipe Pressure Drop Data Class

The input and output data used by external servers for calculation of the pipe pressure drop.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Plumbing PipePressureDropData

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PipePressureDropData : IDisposable

The PipePressureDropData type exposes the following members.

Properties
Name Description
Public property CategoryId The category id of pipe curves. It will be OST_PipeCurves, OST_FlexPipeCurves, or OST_PlaceHolderPipes.
Public property Coefficient The coefficient of the pipe.
Public property Density The density of the pipe. Units: (kg/ft³).
Public property Flow The flow of the pipe. Units: (ft³/s).
Public property FlowState The flowState of the pipe.
Public property Friction The friction of the pipe. Units: (kg/(ft²·s²)).
Public property FrictionFactor The friction factor of the pipe.
Public property InsideDiameter The inside diameter of the pipe. Units: (ft).
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property KLevel The system calculation level.
Public property Length The length of the pipe. Units: (ft).
Public property NominalDiameter The nominal diameter of the pipe. Units: (ft).
Public property OutsideDiameter The outside diameter of the pipe. Units: (ft).
Public property PressureDrop The pressure drop of the pipe. Units: (kg/(ft·s²)).
Public property RelativeRoughness The relative roughness of the pipe.
Public property ReynoldsNumber The reynolds number of the pipe.
Public property Roughness The roughness of the pipe. Units: (ft).
Public property Velocity The velocity of the pipe. Units: (ft/s).
Public property VelocityPressure The velocity pressure of the pipe. Units: (kg/(ft·s²)).
Public property Viscosity The dynamic viscosity of the pipe. Units: (kg/(ft·s)).
Top
Methods
Name Description
Public method Dispose Releases all resources used by the PipePressureDropData
Top
Remarks
Roughness, Length, Flow, Diameter, Density, and Viscosity field values are input data for the calculation. ReynoldsNumber, FlowStatus, Friction, FrictionFactor, Velocity, Coefficient, and PressureDrop are output values.
See Also