RestoreUsers Method


Worksharing Display Settings Restore Users Method

Adds users back to the list of displayed users and permits customization of the graphics. Any usernames that are not currently removed will be ignored. Returns the number of users who were actually restored.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public int RestoreUsers(
	ICollection<string> usersToRestore
)

Parameters

usersToRestore ICollection String
The usernames of the users to restore. Any usernames that are not currently removed will be ignored.

Return Value

Int32
The number of usernames that were actually restored.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
This is the opposite of removing users. Note that the user will be shown with default graphic overrides - any customizations that existed prior to removing the user will not be restored.
See Also