ReportLinkLoadResults Method


Revit Link UIUtils Report Link Load Results Method

This function reports any errors which were encountered when loading the Revit links represented by the given LinkLoadResult map.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void ReportLinkLoadResults(
	Document doc,
	IDictionary<string, LinkLoadResult> loadResults
)

Parameters

doc Document
The document containing the links.
loadResults IDictionary String , LinkLoadResult

A map from the display name of a link to the LinkLoadResult for that link.

Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks

If all links succeeded in loading, the function does nothing. If any links failed to load, this function will display the Unresolved References dialog, giving the user the option to open the Manage Links dialog to correct any problems.

To ensure the dialog fits on the screen, Revit will only list up to ten link names. Additional links will be mentioned as, "And >number< additional links." This is the same behavior Revit's user interface uses.

See Also