Project |
Verifies that there is no existing ProjectLocation with the given name belonging to the given SiteLocation.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool IsProjectLocationNameUnique(
Document document,
string name,
ElementId siteLocationId
)
Parameters
- document Document
- The document to check.
- name String
- The name to check.
- siteLocationId ElementId
- The ElementId of the SiteLocation which the ProjectLocation belongs to.
Return Value
BooleanTrue if the name is unused (among ProjectLocations). False otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |