Specification Property


Fabrication Part Specification Property

The fabrication part specification identifier.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public int Specification { get; set; }

Property Value

Int32
Exceptions
Exception Condition
ArgumentException When setting this property: the specification is invalid for the fabrication part.
InvalidOperationException When setting this property: the specification is not able to be modified. -or- When setting this property: the fabrication part is connected to more than one item. -or- When setting this property: the specification fails to be set by identifier: specId.
Remarks
A value of 0 indicates the specification is set to undefined.
See Also