Rebar |
Create a circumference constraint.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public RebarShapeConstraintCircumference(
ElementId paramId,
RebarShapeArcReferenceType refType
)
Parameters
- paramId ElementId
- The Id of a Rebar Shape parameter.
- refType RebarShapeArcReferenceType
- A choice of rule for measuring the circumference.

Exception | Condition |
---|---|
ArgumentException | paramId is not a valid Element identifier. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |