Extended Property


IExtension Extended Property

Retrieves or set the extension status at the end

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
bool this[
	int index
] { get; set; }

Parameters

index Int32

Property Value

Boolean
Remarks
Property index must be 0 or 1 to indicate two ends, otherwise exceptions will be thrown. For beams, if the beam extension status is changed, other status such as the symbolic extension status, miter status, miter locked status, and other beams extension status will be changed automatically at the same time. This change can protect that a join can have up to two extended beams, if there are two extended beams at the join, they shall be mitered.
See Also