FailuresAccessor Class


Failures Accessor Class

An interface class that provides access to failure information posted in a document and methods to resolve these failures.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB FailuresAccessor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FailuresAccessor : IDisposable

The FailuresAccessor type exposes the following members.

Properties
Name Description
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
Name Description
Public method CanCommitPendingTransaction Checks if pending failure processing can be finished by committing a pending transaction.
Public method CanRollBackPendingTransaction Checks if pending failure processing can be finished by rolling back a pending transaction.
Public method CommitPendingTransaction Finishes pending failures processing by committing the pending transaction.
Public method DeleteAllWarnings Deletes all FailureMessages of severity "Warning" currently posted in a document.
Public method DeleteElements Resolves failures by deletion of elements related to the failures.
Public method DeleteWarning Deletes one specific failure message of severity "Warning".
Public method Dispose Releases all resources used by the FailuresAccessor
Public method GetAttemptedResolutionTypes Returns list of the failure resolution types attempted for the failure in the current transaction.
Public method GetDocument Provides access to a document for which failures are being processed or preprocessed.
Public method GetFailureHandlingOptions Provides access to the failure handling options for the transaction currently being finished.
Public method GetFailureMessages Provides access to the individual failure messages currently posted in the document.
Public method GetFailureMessages(FailureSeverity) Provides access to the individual failure messages if a given severity currently posted in the document.
Public method GetSeverity Provides access to the current failure severity.
Public method GetTransactionName Retrieves the name of the transaction for which failures are being processed.
Public method IsActive Method allows to check if this instance of the accessor is currently active.
Public method IsElementsDeletionPermitted Checks if resolution of the failures by deleting failure elements is permitted.
Public method IsElementsDeletionPermitted(IList ElementId ) Checks if resolution of the failures by deleting given collection of elements is permitted.
Public method IsElementsDeletionPermitted(IList ElementId , String ) Checks if resolution of the failures by deleting given collection of elements is permitted.
Public method IsFailureResolutionPermitted Checks if resolution of failures is permitted.
Public method IsFailureResolutionPermitted(FailureMessageAccessor) Checks if default resolution of the failure is permitted.
Public method IsFailureResolutionPermitted(FailureMessageAccessor, FailureResolutionType) Checks if resolution of the failure using given resolution type is permitted.
Public method IsPending Checks if the failure processing is pending.
Public method IsTransactionBeingCommitted Checks if the transaction for which failures are processed is being committed or rolled back.
Public method JournalFailures Allows to record information about failures in the journal.
Public method PostFailure Posts an additional failure message to be processed for the current transaction.
Public method ReplaceFailures Deletes all failure messages currently posted in a document and replaces them with one "generic" failure.
Public method ResolveFailure Resolves one failure using the failure resolution type last set for it.
Public method ResolveFailures Resolves one or more failures using last set failure resolution type for each of the failures. If failure resolution type was not set for some of failures, default failure resolution type will be used.
Public method RollBackPendingTransaction Finishes pending failures processing by rolling back the pending transaction.
Public method SetFailureHandlingOptions Sets failure handling options for the transaction currently being finished.
Public method SetTransactionName Changes the name of the transaction for which failures are being processed.
Top
Remarks
An instance of this class can be obtained only as an argument passed to interfaces used in the process of failure resolution and is the only available interface to fetch information about failures in a document. While reading from a document during failure processing is allowed, the only way to modify document during failure resolution is via methods provided by this class. After returning from failure processing, the instance of the class is deactivated and cannot be used any longer.
See Also