DGNExportOptions Class


DGNExport Options Class

The export options used by exporting DGN format file.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DGNExportOptions : BaseExportOptions

The DGNExportOptions type exposes the following members.

Constructors
Name Description
Public method DGNExportOptions Constructs a new instance of DGNExportOptions with default values of all properties.
Public method DGNExportOptions(DGNExportOptions) Constructs a new instance of DGNExportOptions as a copy of the export options.
Top
Properties
Name Description
Public property Colors Export color mode. Default value is ExportColorMode.IndexColors.
(Inherited from BaseExportOptions )
Public property FileVersion The DGN file version. Default value of fileVersion is DGNFileFormat.Default.
Public property HatchPatternsFileName Custom hatch patterns (pat) file name.
(Inherited from BaseExportOptions )
Public property HideReferencePlane Whether or not to hide reference planes. Default value is false.
(Inherited from BaseExportOptions )
Public property HideScopeBox Whether or not to hide the scope box. Default value is false.
(Inherited from BaseExportOptions )
Public property HideUnreferenceViewTags Whether or not to hide unreference view tags. Default value is false.
(Inherited from BaseExportOptions )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from BaseExportOptions )
Public property LayerMapping Name of a layer settings standard or filename (with custom layer settings). Valid standards are: DGNV7 (only for DGN), AIA, CP83, BS1192, and ISO13567. default value is "" (empty) which means if no value is set, if no value is set, Revit will use a default value according to the localization.
(Inherited from BaseExportOptions )
Public property MergedViews Whether to merge all views in one file (via XRefs). Default value of mergedViews is false.
Public property PreserveCoincidentLines Whether or not to preserve coincident lines. Default value is false.
(Inherited from BaseExportOptions )
Public property PropOverrides How to export overridden object styles. Default value is PropOverrideMode.ByEntity.
(Inherited from BaseExportOptions )
Public property SeedName The name of the DGN seed. Default value of seedName is empty.
Public property WorkingUnits If true, Main Units will be used. If false, Sub Units will be used. Default value of WorkingUnits is true.
Top
Methods
Name Description
Public method Dispose
(Inherited from BaseExportOptions )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetExportFontTable Gets font table.
(Inherited from BaseExportOptions )
Public method GetExportLayerTable Gets the layer table.
(Inherited from BaseExportOptions )
Public method GetExportLinetypeTable Gets a copy of the line type table.
(Inherited from BaseExportOptions )
Public method GetExportLineweightTable Gets a copy of the line weight table.
Public method GetExportPatternTable Gets a copy of the pattern table.
(Inherited from BaseExportOptions )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method Static member GetPredefinedOptions Returns an instance DGNExportOptions containing settings from a predefined export setup.
Public method Static member GetPredefinedSetupNames Returns a list of names of predefined setups of DGN export options.
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method SetExportFontTable Sets font table to option.
(Inherited from BaseExportOptions )
Public method SetExportLayerTable Sets layer table back to option
(Inherited from BaseExportOptions )
Public method SetExportLinetypeTable Sets the line type table to use during export.
(Inherited from BaseExportOptions )
Public method SetExportLineweightTable Sets the line weight table to use during export.
Public method SetExportPatternTable Sets the pattern table to use during export.
(Inherited from BaseExportOptions )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also