Failure |
Sets elements that have caused the failure.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- idsToShow ICollection ElementId
- The elements that have caused the failure.
Return Value
FailureMessageThe FailureMessage.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | This FailureMessage is already posted to a document |

In the Revit error dialog these elements will be highlighted to the user and can be deleted by user via extended error dialog.