Element Bounding |
Retrieves a box that circumscribes all geometry of the element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Pass in a view to query view-specific (e.g., cut) geometry or for model geometry. If the view box is not known or cannot be calculated, this will return the model box; if the model box is not known, this will return . The box will always be aligned to the default axes of the model coordinate system (thus no rotation should be applied to the return value). Also note that this bounding box volume may enclose geometry that is not obvious. For example, the "flip controls" that could be part of a family will be included in the computation of the bounding box even though they are not always visible in the family instance of the family.

private void GetElementBoundingBox(Autodesk.Revit.DB.Document document, Autodesk.Revit.DB.Element element)
{
// Get the BoundingBox instance for current view.
BoundingBoxXYZ box = element.get_BoundingBox(document.ActiveView);
if (null == box)
{
throw new Exception("Selected element doesn't contain a bounding box.");
}
string info = "Bounding box is enabled: " + box.Enabled.ToString();
// Give the user some information.
TaskDialog.Show("Revit",info);
}