DocumentReloadLatestProgressChangedEventArgs Class


Document Reload Latest Progress Changed Event Args Class

The event arguments used during the reload latest phase of [!:Autodesk::Revit::ApplicationServices::Application::WorksharedOperationProgressChanged] .
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB.Events
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DocumentReloadLatestProgressChangedEventArgs : DataTransferProgressChangedEventArgs

The DocumentReloadLatestProgressChangedEventArgs type exposes the following members.

Properties
Name Description
Public property IsMerging Indicates if it is merging downloaded data.
Public property ReloadLatestFinished Indicates if current 'reload latest' progress is finished.
Public property RetryTimes The number of times Revit has tried to Reload Latest. Its value is '0' at the first time.
Top
Methods
Name Description
Top
Remarks
It is NOT recommended to do any time-consuming work when handling WorksharedOperationProgressChanged event. This can increase workshared operation time. Name correction - it is renamed from 'DocumentReloadLatestProgessChangedEventArgs' released since 2017 Subscription Update.
See Also