CylindricalFace Class


Cylindrical Face Class

A cylindrical face of a 3d solid or open shell.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CylindricalFace : Face

The CylindricalFace type exposes the following members.

Properties
Name Description
Public property Area The area of this face.
(Inherited from Face )
Public property Axis Axis of the surface.
Public property EdgeLoops A collection of edge loops. Each edge loop represents one of the closed boundaries of the face.
(Inherited from Face )
Public property Code example GraphicsStyleId The ElementId of the GeometryObject's GraphicsStyle
(Inherited from GeometryObject )
Public property HasRegions Identifies if the face contains regions (which can be created, for example, by the Split Face command).
(Inherited from Face )
Public property Id A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
(Inherited from GeometryObject )
Public property IsCyclic Indicates whether the underlying surface is periodic in the specified parametric direction.
(Inherited from Face )
Public property IsElementGeometry Indicates whether this geometry is obtained directly from an Element.
(Inherited from GeometryObject )
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property IsTwoSided Determines if a face is two-sided (degenerate).
(Inherited from Face )
Public property MaterialElementId The element ID of the material from which this face is composed.
(Inherited from Face )
Public property OrientationMatchesSurfaceOrientation Returns true if this face's orientation matches the orientation of the face's surface, false if they have opposite orientations.
(Inherited from Face )
Public property Origin Origin of the surface.
Public property Period The period of the underlying surface in the specified parametric direction.
(Inherited from Face )
Public property Radius Radii of the surface.
Public property Reference Returns a stable reference to the face.
(Inherited from Face )
Public property Visibility The visibility.
(Inherited from GeometryObject )
Top
Methods
Name Description
Public method ComputeDerivatives Returns the first partial derivatives of the underlying surface at the specified point.
(Inherited from Face )
Public method ComputeNormal Returns the normal vector for the face at the given point.
(Inherited from Face )
Public method ComputeSecondDerivatives Returns the second partial derivatives of the face at the specified point.
(Inherited from Face )
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified Object is equal to the current Object .
(Inherited from GeometryObject )
Public method Evaluate Evaluates and returns the XYZ coordinates of a point at the indicated UV parameterization of the face.
(Inherited from Face )
Public method GetBoundingBox Returns the UV bounding box of the face.
(Inherited from Face )
Public method GetEdgesAsCurveLoops Returns a list of closed curve loops that correspond to the edge loops of the face. Curves in each curve loop correspond to individual edges.
(Inherited from Face )
Public method GetHashCode Gets the integer value of the geometry object as hash code
(Inherited from GeometryObject )
Public method GetRegions Gets the face regions (created, for example, by the Split Face command) of the face.
(Inherited from Face )
Public method GetSurface Returns a copy of this face's surface.
(Inherited from Face )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Intersect(Curve) Calculates the intersection of the specified curve with this face.
(Inherited from Face )
Public method Intersect(Face) Calculates the intersection of the specified face with this face and returns the intersection results.
(Inherited from Face )
Public method Intersect(Curve, IntersectionResultArray ) Calculates the intersection of the specified curve with this face and returns the intersection results.
(Inherited from Face )
Public method Intersect(Face, Curve ) Calculates the intersection of the specified face with this face and returns the intersection results.
(Inherited from Face )
Public method IsInside(UV) Indicates whether the specified point is within this face.
(Inherited from Face )
Public method IsInside(UV, IntersectionResult ) Indicates whether the specified point is within this face and outputs additional information about the point location.
(Inherited from Face )
Public method Project Projects the specified point on the face.
(Inherited from Face )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Public method Code example Triangulate Returns a triangular mesh approximation to the face.
(Inherited from Face )
Public method Triangulate(Double) Returns a triangular mesh approximation to the face.
(Inherited from Face )
Top
Remarks
For details on the parameterization, refer to the documentation for CylindricalSurface .
Example
private void GetCylindricalFaceInfo(Face face)
{
    CylindricalFace cylindricalFace = face as CylindricalFace;
    if (null != cylindricalFace)
    {
       XYZ axis = cylindricalFace.Axis;
       XYZ origin = cylindricalFace.Origin;
       XYZ radius = cylindricalFace.get_Radius(0);
    }
}
See Also