CylindricalFace Class


Cylindrical Face Class

A cylindrical face of a 3d solid or open shell.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class CylindricalFace : Face

The CylindricalFace type exposes the following members.

Properties
Name Description
Public property Axis Axis of the surface.
Public property Origin Origin of the surface.
Public property Radius Radii of the surface.
Top
Methods
Name Description
Top
Remarks
For details on the parameterization, refer to the documentation for CylindricalSurface .
Example
private void GetCylindricalFaceInfo(Face face)
{
    CylindricalFace cylindricalFace = face as CylindricalFace;
    if (null != cylindricalFace)
    {
       XYZ axis = cylindricalFace.Axis;
       XYZ origin = cylindricalFace.Origin;
       XYZ radius = cylindricalFace.get_Radius(0);
    }
}
See Also