GetCurveUV Method (Int32)


Edge Get Curve UV(Int 32) Method

Calculate a 2D curve that represents the edge in the uv-parameter plane of one of the edge's faces. The output curve's direction will follow the parametric direction of the edge, not the topological direction of the edge on the given face.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public CurveUV GetCurveUV(
	int index
)

Parameters

index Int32
The index of the face (0 or 1).

Return Value

CurveUV
If successful, returns the calculated CurveUV, otherwise.
Exceptions
Exception Condition
ArgumentOutOfRangeException Thrown when the specified index is not 0 or 1.
See Also