ReorderRevisionSequence Method


Revision Reorder Revision Sequence Method

Reorders the sequence of Revisions in the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static void ReorderRevisionSequence(
	Document document,
	IList<ElementId> newSequence
)

Parameters

document Document
The document in which the Revision sequence should be reordered.
newSequence IList ElementId
The new sequence of Revisions.
Exceptions
Exception Condition
ArgumentException newSequence does not contain every Revision exactly once.
ArgumentNullException A non-optional argument was null
Remarks
This method allows the caller to change the sequence of the Revisions within the project by specifying the new sequence. The specified sequence must include every Revision in the project exactly once.

Note that changing the sequence of Revisions can change the SequenceNumber and RevisionNumber of Revisions that have already been issued.

See Also