Topography |
Starts a topography surface edit mode for an existing TopographySurface element.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- topoSurfaceId ElementId
- The TopographySurface element to be edited.
Return Value
ElementIdThe Id of the topography Surface being edited.

Exception | Condition |
---|---|
ArgumentException | The ElementId topoSurfaceId does not represent a TopographySurface. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | This TopographyEditScope is not permitted to start at this moment for one of the following possible reasons: The document is in read-only state, or the document is currently modifiable, or there already is another edit mode active in the document. |

The application will need to start a transaction to actually make changes to the TopographySurface element. TopographyEditScope can only be started when there is no transaction active, thus it does not work for commands running in automatic transaction mode. Like all Start methods in any edit scope object this too returns an Id of the element in the edit session, even though in this case here it always equals to the given topoSurfaceId.