AssignedFlowFactor Property


Connector Assigned Flow Factor Property

The assigned flow factor of this connector.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double AssignedFlowFactor { get; set; }

Property Value

Double
Exceptions
Exception Condition
InvalidOperationException Thrown when get assigned flow factor from a connector not in family instance. Thrown when the connector's domain is not DomainHvac or DomainPiping.
ArgumentException Throw when set an invalid value.
InvalidOperationException Thrown on failure to get or set assigned flow factor.
Remarks
Assigned flow factor may be assigned for connectors of some family instances. In order to set this property, it must be mapped to a writable instance parameter in the family definition.
See Also