ReferencePlane Class


Reference Plane Class

Represents a reference plane of Autodesk Revit.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ReferencePlane : DatumPlane

The ReferencePlane type exposes the following members.

Properties
Name Description
Public property BubbleEnd The bubble end of the reference plane.
Public property Direction The direction of the reference plane.
Public property FreeEnd The free end of the reference plane.
Public property Name The name property of the reference plane.
Public property Normal The normal vector of the reference plane.
Top
Methods
Name Description
Public method Flip Flips the orientation of the reference plane.
Public method GetPlane Returns the geometry plane to which the reference plane is assigned.
Public method GetReference Returns the geometry reference of the reference plane.
Top
Example
private void Getinfo_ReferencePlane(ReferencePlane refPlane)
{
    string message = "Reference Plane: ";
    //get the bubble end of the reference plane
    XYZ bubbleEnd = refPlane.BubbleEnd;
    message += "\nBubble end: (" + bubbleEnd.X + ", "
                       + bubbleEnd.Y + ", " + bubbleEnd.Z + ")";

    //get the direction of the reference plane
    XYZ direction = refPlane.Direction;
    message += "\nDirection: (" + direction.X + ", "
                    + direction.Y + ", " + direction.Z + ")";

    //get the freeEnd of the reference plane
    XYZ freeEnd = refPlane.FreeEnd;
    message += "\nFree End: (" + freeEnd.X + ", "
                    + freeEnd.Y + ", " + freeEnd.Z + ")";

    //get the name of the reference plane
    message += "\nName: " + refPlane.Name;

    //get the normal vector of the reference plane
    XYZ normal = refPlane.Normal;
    message += "\nNormal vector: (" + normal.X + ", "
                    + normal.Y + ", " + normal.Z + ")";

    //get the geometry plane to which the reference plane assigned 
    Autodesk.Revit.DB.Plane plane = refPlane.GetPlane();
    message += "\norigin of the plane: (" + plane.Origin.X + ", "
                    + plane.Origin.Y + ", " + plane.Origin.Z + ")";

    message += "\nnormal of the plane: (" + plane.Normal.X + ", "
                    + plane.Normal.Y + ", " + plane.Normal.Z + ")";

    message += "\nXvec of the plane: (" + plane.XVec.X + ", "
                    + plane.XVec.Y + ", " + plane.XVec.Z + ")";

    message += "\nYvec of the plane: (" + plane.YVec.X + ", "
                    + plane.YVec.Y + ", " + plane.YVec.Z + ")";

    TaskDialog.Show("Revit",message);
}
See Also