Line Class


Line Class

A line in space.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Line : Curve

The Line type exposes the following members.

Properties
Name Description
Public property ApproximateLength The approximate length of the curve.
(Inherited from Curve )
Public property Direction Returns the direction of the line.
Public property Code example GraphicsStyleId The ElementId of the GeometryObject's GraphicsStyle
(Inherited from GeometryObject )
Public property Id A unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
(Inherited from GeometryObject )
Public property IsBound Describes whether the parameter of the curve is restricted to a particular interval.
(Inherited from Curve )
Public property IsClosed Describes whether the curve is closed.
(Inherited from Curve )
Public property IsCyclic The boolean value that indicates whether this curve is cyclic.
(Inherited from Curve )
Public property IsElementGeometry Indicates whether this geometry is obtained directly from an Element.
(Inherited from GeometryObject )
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Public property Length The exact length of the curve.
(Inherited from Curve )
Public property Origin Returns the origin of the line.
Public property Period The period of this curve.
(Inherited from Curve )
Public property Reference Returns a stable reference to the curve.
(Inherited from Curve )
Public property Visibility The visibility.
(Inherited from GeometryObject )
Top
Methods
Name Description
Public method Clone Returns a copy of this curve.
(Inherited from Curve )
Public method ComputeClosestPoints Find the closest points between two curves. Closest points mean closest pairs of points, each pair consisting of a point on this, say P1, and a point on other curve, say P2. P1 and P2 are closest locally. Each pairs of closest points will be represented by the corresponding parameter values with respect to the two curves and the 3d points. A closest pair is also known as a pair of critical points of the distance function between points of the two curves. If the input parameter returnAllCriticalPoints is set to false, then the function will return only pairs with minimum distance.
(Inherited from Curve )
Public method ComputeDerivatives Returns the vectors describing the curve at the specified parameter.
(Inherited from Curve )
Public method ComputeNormalizedParameter Computes the normalized curve parameter from the raw parameter.
(Inherited from Curve )
Public method ComputeRawParameter Computes the raw parameter from the normalized parameter.
(Inherited from Curve )
Public method Static member Code example CreateBound Creates a new instance of a bound linear curve.
Public method CreateOffset Creates a new curve that is an offset of the existing curve.
(Inherited from Curve )
Public method CreateReversed Creates a new curve with the opposite orientation of the existing curve.
(Inherited from Curve )
Public method CreateTransformed Crates a new instance of a curve as a transformation of this curve.
(Inherited from Curve )
Public method Static member Code example CreateUnbound Creates a new instance of an unbound linear curve.
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Distance Returns the shortest distance from the specified point to this curve.
(Inherited from Curve )
Public method Equals Determines whether the specified Object is equal to the current Object .
(Inherited from GeometryObject )
Public method Evaluate Evaluates and returns the point that matches a parameter along the curve.
(Inherited from Curve )
Public method GetEndParameter Returns the raw parameter value at the start or end of this curve.
(Inherited from Curve )
Public method GetEndPoint Returns the 3D point at the start or end of this curve.
(Inherited from Curve )
Public method GetEndPointReference Returns a stable reference to the start point or the end point of the curve.
(Inherited from Curve )
Public method GetHashCode Gets the integer value of the geometry object as hash code
(Inherited from GeometryObject )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Intersect(Curve) Calculates the intersection of this curve with the specified curve.
(Inherited from Curve )
Public method Intersect(Curve, IntersectionResultArray ) Calculates the intersection of this curve with the specified curve and returns the intersection results.
(Inherited from Curve )
Public method IsInside(Double) Indicates whether the specified parameter value is within this curve's bounds.
(Inherited from Curve )
Public method IsInside(Double, Int32 ) Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.
(Inherited from Curve )
Public method MakeBound Changes the bounds of this curve to the specified values.
(Inherited from Curve )
Public method MakeUnbound Makes this curve unbound.
(Inherited from Curve )
Public method Project Projects the specified point on this curve.
(Inherited from Curve )
Public method SetGraphicsStyleId Sets the graphics style id for this curve.
(Inherited from Curve )
Public method Tessellate Valid only if the curve is bound. Returns a polyline approximation to the curve.
(Inherited from Curve )
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also