Line Class


Line Class

A line in space.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Line : Curve

The Line type exposes the following members.

Properties
Name Description
Public property Direction Returns the direction of the line.
Public property Origin Returns the origin of the line.
Top
Methods
Name Description
Public method Static member Code example CreateBound Creates a new instance of a bound linear curve.
Public method Static member Code example CreateUnbound Creates a new instance of an unbound linear curve.
Top
See Also