Geometry |
A utility that allows construction of basic solid shapes.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The GeometryCreationUtilities type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | CreateBlendGeometry(CurveLoop, CurveLoop, ICollection VertexPair ) | Creates a solid by blending two closed curve loops lying in non-coincident planes. |
![]() ![]() | CreateBlendGeometry(CurveLoop, CurveLoop, ICollection VertexPair , SolidOptions) | Creates a solid by blending two closed curve loops lying in non-coincident planes. |
![]() ![]() | CreateExtrusionGeometry(IList CurveLoop , XYZ, Double) | Creates a solid by linearly extruding one or more closed coplanar curve loops. |
![]() ![]() | CreateExtrusionGeometry(IList CurveLoop , XYZ, Double, SolidOptions) | Creates a solid by linearly extruding one or more closed coplanar curve loops. |
![]() ![]() | CreateFixedReferenceSweptGeometry(CurveLoop, Int32, Double, IList CurveLoop , XYZ) | Creates a solid by sweeping one or more closed coplanar curve loops along a path while keeping the profile plane oriented so that a line in the plane that is initially perpendicular to a given fixed direction remains perpendicular as the profile is swept along the path. |
![]() ![]() | CreateFixedReferenceSweptGeometry(CurveLoop, Int32, Double, IList CurveLoop , XYZ, SolidOptions) | Creates a solid by sweeping one or more closed coplanar curve loops along a path while keeping the profile plane oriented so that a line in the plane that is initially perpendicular to a given fixed direction remains perpendicular as the profile is swept along the path. |
![]() ![]() | CreateLoftGeometry | Creates a solid or open shell geometry by lofting between a sequence of curve loops. |
![]() ![]() | CreateRevolvedGeometry(Frame, IList CurveLoop , Double, Double) | Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle. |
![]() ![]() | CreateRevolvedGeometry(Frame, IList CurveLoop , Double, Double, SolidOptions) | Creates a solid of revolution by revolving a set of closed curve loops around an axis by a specified angle. |
![]() ![]() | CreateSweptBlendGeometry(Curve, IList Double , IList CurveLoop , IList ICollection VertexPair ) | Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve. |
![]() ![]() | CreateSweptBlendGeometry(Curve, IList Double , IList CurveLoop , IList ICollection VertexPair , SolidOptions) | Creates a solid by simultaneously sweeping and blending two or more closed planar curve loops along a single curve. |
![]() ![]() | CreateSweptGeometry(CurveLoop, Int32, Double, IList CurveLoop ) | Creates a solid by sweeping one or more closed coplanar curve loops along a path. |
![]() ![]() | CreateSweptGeometry(CurveLoop, Int32, Double, IList CurveLoop , SolidOptions) | Creates a solid by sweeping one or more closed coplanar curve loops along a path. |

The shapes created by these utilities are not a part of any Revit document, but can be used in conjunction with other geometric utilities from within API applications.