ViewSheetSetting Class


View Sheet Setting Class

Represents the View/Sheet Set (Application Menu->Print) within Autodesk Revit.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB ViewSheetSetting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ViewSheetSetting : APIObject

The ViewSheetSetting type exposes the following members.

Properties
Name Description
Public property AvailableViews All views that can be printed.
Public property CurrentViewSheetSet The current view sheet set of PrintSetup.
Public property InSession The in-session view sheet set of Print Setup.
Public property Code example IsReadOnly Identifies if the object is read-only or modifiable.
(Inherited from APIObject )
Top
Methods
Name Description
Public method Delete Delete the current view sheet set, and make the In-Session set as the current one.
Public method Dispose Causes the object to release immediately any resources it may be utilizing.
(Inherited from APIObject )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method Rename Rename the current view sheet set.
Public method Revert Revert the current view sheet set.
Public method Save Save the changes for the current view sheet set.
Public method SaveAs Save the current view sheet set to another view sheet set with the specified name.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Top
See Also