ViewSheetSetting Class


View Sheet Setting Class

Represents the View/Sheet Set (Application Menu->Print) within Autodesk Revit.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB APIObject
Autodesk.Revit.DB ViewSheetSetting

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ViewSheetSetting : APIObject

The ViewSheetSetting type exposes the following members.

Properties
Name Description
Public property AvailableViews All views that can be printed.
Public property CurrentViewSheetSet The current view sheet set of PrintSetup.
Public property InSession The in-session view sheet set of Print Setup.
Top
Methods
Name Description
Public method Delete Delete the current view sheet set, and make the In-Session set as the current one.
Public method Rename Rename the current view sheet set.
Public method Revert Revert the current view sheet set.
Public method Save Save the changes for the current view sheet set.
Public method SaveAs Save the current view sheet set to another view sheet set with the specified name.
Top
See Also