AdvancedOpaque Class


Advanced Opaque Class

A static class that provides access to the property names that appear in the AdvancedOpaque visual asset schema.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.Visual AdvancedOpaque

Namespace: Autodesk.Revit.DB.Visual
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class AdvancedOpaque

The AdvancedOpaque type exposes the following members.

Properties
Name Description
Public property Static member OpaqueAlbedo The property labeled "Color" from the "AdvancedOpaque" schema.
Public property Static member OpaqueEmission The property labeled "Emission" from the "AdvancedOpaque" schema.
Public property Static member OpaqueF0 The property labeled "Specular reflectance" from the "AdvancedOpaque" schema.
Public property Static member OpaqueLuminance The property labeled "Emissive Luminance" from the "AdvancedOpaque" schema.
Public property Static member OpaqueLuminanceModifier The property labeled "Luminance Scale" from the "AdvancedOpaque" schema.
Public property Static member OpaqueMfp The property labeled "Translucency Depth" from the "AdvancedOpaque" schema.
Public property Static member OpaqueMfpModifier The property labeled "Translucency Weight" from the "AdvancedOpaque" schema.
Public property Static member OpaqueTranslucency The property labeled "Translucency" from the "AdvancedOpaque" schema.
Public property Static member SurfaceAlbedo The property labeled "Color" from the "AdvancedOpaque" schema.
Public property Static member SurfaceAnisotropy The property labeled "Anisotropy" from the "AdvancedOpaque" schema.
Public property Static member SurfaceCutout The property labeled "Image" from the "AdvancedOpaque" schema.
Public property Static member SurfaceNdfType The property labeled "NDF" from the "AdvancedOpaque" schema.
Public property Static member SurfaceNormal The property labeled "Image" from the "AdvancedOpaque" schema.
Public property Static member SurfaceRotation The property labeled "Rotation" from the "AdvancedOpaque" schema.
Public property Static member SurfaceRoughness The property labeled "Roughness" from the "AdvancedOpaque" schema.
Top
See Also