gbXMLSurfaceType Enumeration


gb XMLSurface Type Enumeration

This enumeration corresponds to the surfaceType attribute in gbXML and identifies the type of surface defined.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public enum gbXMLSurfaceType
Members
Member name Value Description
InteriorWall 0 Interior wall.
ExteriorWall 1 Exterior wall.
Roof 2 Roof.
InteriorFloor 3 Interior floor.
ExposedFloor 4 Exposed floor.
Shade 5 Shade.
UndergroundWall 6 Underground wall.
UndergroundSlab 7 Underground slab.
Ceiling 8 Ceiling.
SurfaceAir 9 Surface air.
UndergroundCeiling 10 Underground ceiling.
RaisedFloor 11 Raised floor.
SlabOnGrade 12 Slab on grade.
NoOfSurfaceTypes 13 No of surface types.
See Also