Element |
A filter used to find elements matching a structural type.

System Object
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementQuickFilter
Autodesk.Revit.DB ElementStructuralTypeFilter
Autodesk.Revit.DB ElementFilter
Autodesk.Revit.DB ElementQuickFilter
Autodesk.Revit.DB ElementStructuralTypeFilter
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The ElementStructuralTypeFilter type exposes the following members.

Name | Description | |
---|---|---|
![]() | ElementStructuralTypeFilter(StructuralType) | Constructs a new instance of a filter to match elements by structural type. |
![]() | ElementStructuralTypeFilter(StructuralType, Boolean) | Constructs a new instance of a filter to match elements by structural type, with the option to match all elements which are of the given structural type. |

Name | Description | |
---|---|---|
![]() | StructuralType | The structural type. |

Name | Description | |
---|---|---|

This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.