AreValidDirectShapeReferenceOptions Method


Direct Shape Are Valid Direct Shape Reference Options Method

Validates that the input DirectShapeReferenceOptions are suitable for creating a direct shape reference object. If the options specify an ExternalGeometryId, it must not correspond to any existing reference object belonging to the DirectShape.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool AreValidDirectShapeReferenceOptions(
	DirectShapeReferenceOptions options
)

Parameters

options DirectShapeReferenceOptions
The options to test.

Return Value

Boolean
True if the options can be used to add a reference object to this DirectShape.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also