BuiltInFailures.ColumnFailures Class


Built In Failures Column Failures Class

Failures about Columns.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB BuiltInFailures ColumnFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static class ColumnFailures

The BuiltInFailures ColumnFailures type exposes the following members.

Properties
Name Description
Public property Static member ColumnAndTargetAreConcrete Column and target are both concrete. Geometries have been joined.
Public property Static member ColumnBaseAboveTopError The column base can't be moved above its top.
Public property Static member ColumnBaseAboveTopFailure The column base can't be moved above its top.
Public property Static member ColumnJoinNonhitFailure The highlighted column can't maintain attachment to the target. It will be treated as unattached until it can intersect.
Public property Static member ColumnTopBelowBaseError The column top can't be moved below its base.
Public property Static member ColumnTopBelowBaseFailure The column top can't be moved below its base.
Public property Static member ColumnZeroHeightError The column can't have zero height
Public property Static member ColumnZeroHeightFailure The column can't have zero height
Top
See Also