SetCurveInView Method


Datum Plane Set Curve In View Method

Sets the extents to match the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetCurveInView(
	DatumExtentType extentMode,
	View view,
	Curve curve
)

Parameters

extentMode DatumExtentType
The extent type.
view View
The view.
curve Curve
The curve.
Exceptions
Exception Condition
ArgumentException The datum plane cannot be visible in the view. -or- The curve is unbound or not coincident with the original one of the datum plane.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also