CanBeExcavatedBy Method


Toposolid Can Be Excavated By Method

Checks if the given element can be used to excavate the toposolid.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool CanBeExcavatedBy(
	ElementId elementId
)

Parameters

elementId ElementId
Id of the element

Return Value

Boolean
True if the element can be used to excavate the toposolid.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also