SetLayoutFixedDistance Method


Spacing Rule Set Layout Fixed Distance Method

Set the Layout property to FixedDistance.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetLayoutFixedDistance(
	double distance,
	SpacingRuleJustification just,
	double gridlinesRotation,
	double offset
)

Parameters

distance Double
just SpacingRuleJustification
gridlinesRotation Double
offset Double
Remarks
When changing the Layout to FixedDistance, you must also simultaneously set the Distance, Justification, GridlinesRotation, and Offset properties.
See Also