GetExternalFileReference Method


External File Utils Get External File Reference Method

Gets the external file referencing data for the given element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ExternalFileReference GetExternalFileReference(
	Document aDoc,
	ElementId elemId
)

Parameters

aDoc Document
A Revit Document.
elemId ElementId
The element whose external file reference we want.

Return Value

ExternalFileReference
An object containing path and type information for the given element's external file.
Exceptions
Exception Condition
ArgumentException The element elemId does not exist in the document -or- elemId does not represent an external file reference.
ArgumentNullException A non-optional argument was null
See Also